Störung auf Webhosting-System venus.a1a-server.de

Nach vier Jahren problemloser Betrieb gibt es aktuell Störungen auf unserem Webhosting-System Venus.

Betroffen ist die Überprüfung des Passwortes bei geschützten Verzeichnissen (Basic bzw. Digest Auth), die über Confixx oder von Hand angelegt wurden.

Um das Problem zu lösen, werden wir am heutigen 22.07.2011, ab 23:30 Uhr Wartungsarbeiten am System durchführen. Dabei wird sowohl der Arbeitsspeicher des Systems geprüft und (falls nötig) ausgetauscht, sowie u.U. der Server neu installiert. Datenverluste sind nicht zu erwarten, Kundendaten sind bei einer Neuinstallation nicht betroffen.

Mit Ausfällen rechnen müssen alle Webhosting-Kunden, deren Benutzername mit „web“ beginnt. Das Mailsystem befindet sich auf anderen Systemen und somit nicht beeinträchtigt!

[Update 00:30 Uhr: Die Wartungsarbeiten wurden erfolgreich abgeschlossen, das System steht nun wieder wie gewohnt zur Verfügung. Zusammen mit dem Austausch des bisherigen Arbeitsspeichers haben wir ein Upgrade durchgeführt, so dass die Performance des Systems nun besser sein wird als zuvor.]

Bei der angesprochenen Fehlerbeschreibung des Passwortschutzes wird zwar vermeintlich das Passwort akzeptiert, allerdings dann keine Inhalte angezeigt – sondern lediglich eine weisse Seite.

In den globalen Logdateien findet sich ein Hinweis auf „[notice] child pid 3028 exit signal Bus error (7) „.

Um dem Problem auf die Schliche zu kommen, wurde der Apache veranlasst, bei solchen „Segmentation Faults“ einen kompletten Statusbericht, sog. Backtrace, zu speichern. Demnach tritt dieser Fehler beim Versuch auf, die Funktion „memset()“ aufzurufen.

Die Ursache für einen Fehler hier kann sowohl bei der Soft-, als auch bei der Hardware liegen: ein Defekt des Arbeitsspeichers, der bei memset() angesprochen wird, ist genauso möglich, wie ein Fehler in der Software, die Aufrufe tätigt, die eigentlich nicht möglich sein sollten.

Wir werden daher sowohl den Arbeitsspeicher austauschen und gleichzeitig aufrüsten, als auch eine Neuinstallation des Systems durchführen, falls es nötig sein sollte.

Post navigation


Kommentare

  • Oliver Eberlein

    Hallo,

    wollte mal fragen ob Sie Ihr Problem lösen konnten. Bin zur Zeit auch auf der Suche nach der Ursache eines „exit signal Bus error (7)“. Ich selbst setze für einen Kunden Debian/Squeeze mit Apache/php5 ein, alles aus den Paketen. Kunde betrfeut selbst ein Typo3. Zur Zeit lasse ich einen Memtest laufen. Für eine Info wäre ich dankbar, Gruss aus Köln, Oliver Eberlein

    • Anton Dollmaier

      Guten Nachmittag,

      das Problem „exit signal Bus error (7)“ konnte durch eine Neuinstallation mit Arch-Wechsel (x86 -> x64) gelöst werden – allerdings treten nun „child died with signal 11“-Fehler auf, die aber bisher keine konkreten Probleme verursachen. Neben dem Arch-Wechsel wurde außerdem von suPHP auf mpm-ITK mit mod_php5 umgestellt, welcher bessere Leistung zeigt als suPHP/PHP über CGI.
      Der RAM ist jedenfalls nicht die Ursache des Problems, der Test war fehlerfrei sowie der komplette Austausch ohne Besserung.

      Somit verbleiben nur noch Defekte auf dem Mainboard, der CPU oder in der Software.

      Kernel scheidet aus, 2.6.32-5 läuft seit 26.06., die Probleme traten allerdings bereits am 21.06.2011 erstmals auf. Des weiteren laufen andere Maschinen mit gleicher Konfiguration ohne den Fehler.

      Viel Erfolg bei der Behebung!

Comments are closed.